[Lldb-commits] [PATCH] D139066: [lldb] Make sure the value of `eSymbolContextVariable` is not conflicting with `RESOLVED_FRAME_CODE_ADDR`
Argyrios Kyrtzidis via Phabricator via lldb-commits
lldb-commits at lists.llvm.org
Mon Dec 5 11:30:12 PST 2022
akyrtzi added a comment.
I prefer my original version because:
- `eSymbolContextLastItem` is not an appropriate name for collection of bits, it should be named like `eSymbolContextReallyEverything` or something, which then makes things a bit confusing due to having multiple "everything" enums.
- I like the code consistency and readability of all `RESOLVED_*` macros here being shifts by one of the previous bit. When I first read this code I had to stop and think about why `RESOLVED_FRAME_CODE_ADDR` is different than the rest; "eSymbolContextLastItem << 1" is clearer to understand IMO, particularly in the context of the other macros.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D139066/new/
https://reviews.llvm.org/D139066
More information about the lldb-commits
mailing list