[Lldb-commits] [PATCH] D139054: Delay calling ObjC class list read utility functions very early in process startup
Jonas Devlieghere via Phabricator via lldb-commits
lldb-commits at lists.llvm.org
Wed Nov 30 17:02:47 PST 2022
JDevlieghere added inline comments.
================
Comment at: lldb/source/Plugins/LanguageRuntime/ObjC/AppleObjCRuntime/AppleObjCRuntimeV2.cpp:2519-2520
+ case SharedCacheWarningReason::eExpressionUnableToRun:
+ Debugger::ReportWarning("Objective-C class names could not be read "
+ "right now, will retry later.\n",
+ debugger.GetID(), nullptr);
----------------
[begin bikeshedding]
Could we be more descriptive? Right now this sounds unactionable, which to be fair, it kind of is.
How about "could not execute support code to read Objective-C class data because it's not yet safe to do so and will be retried later.
[end bikeshedding]
Regardless we should say "class data" to match the other warnings or change those to say "class names".
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D139054/new/
https://reviews.llvm.org/D139054
More information about the lldb-commits
mailing list