[Lldb-commits] [PATCH] D133259: [lldb] Don't assume name of libc++ inline namespace in LibCxxUnorderedMap
Jonas Devlieghere via Phabricator via lldb-commits
lldb-commits at lists.llvm.org
Wed Sep 7 17:16:40 PDT 2022
JDevlieghere added inline comments.
================
Comment at: lldb/source/Plugins/Language/CPlusPlus/LibCxxUnorderedMap.cpp:70
+static void consumeNamespace(llvm::StringRef &name) {
+ // Delete past an inline namespace, if any: __[a-zA-Z0-9_]+::
----------------
rupprecht wrote:
> nit: this consumes just the inline namespace, so I think `consumeInlineNamespace` might be a better name. I don't feel that strongly though so I'll leave it up to you.
Rather than modifying the passed-in string, would it make sense to return a `llvm::StringRef`?
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D133259/new/
https://reviews.llvm.org/D133259
More information about the lldb-commits
mailing list