[Lldb-commits] [PATCH] D131605: [lldb][tests] Test queue-specific breakpoints

Chelsea Cassanova via Phabricator via lldb-commits lldb-commits at lists.llvm.org
Fri Aug 12 13:49:09 PDT 2022


cassanova added inline comments.


================
Comment at: lldb/test/API/macosx/queues/TestQueues.py:204-206
+        process_info = lldbutil.run_to_name_breakpoint(self, "stopper", only_one_thread=False)
+        main_thread = process_info[2]
+        queue_breakpoint = process_info[3]
----------------
mib wrote:
> Why not do it this way ? Takes less space and it's easier to read (for people who don't know what `process_info[2]` and `process_info[3]` refers to)
This is a much cleaner way to write it :)


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D131605/new/

https://reviews.llvm.org/D131605



More information about the lldb-commits mailing list