[Lldb-commits] [PATCH] D129364: [LLDB][DataFormatter] Add data formatter for libcxx std::unordered_map iterator

Michael Buch via Phabricator via lldb-commits lldb-commits at lists.llvm.org
Tue Jul 12 02:01:45 PDT 2022


Michael137 marked an inline comment as done.
Michael137 added inline comments.


================
Comment at: lldb/source/Plugins/Language/CPlusPlus/LibCxx.cpp:411
+                       ".__i_.__node_", nullptr, nullptr,
+                       ValueObject::GetValueForExpressionPathOptions()
+                           .DontCheckDotVsArrowSyntax()
----------------
aprantl wrote:
> Does this get more readable if we assign this subexpression to an auto helper variable?
Definitely :)


================
Comment at: lldb/test/API/functionalities/data-formatter/data-formatter-stl/libcxx/unordered_map/TestDataFormatterLibccUnorderedMap.py:13
+    @add_test_categories(['libc++'])
+    def test_with_run_command(self):
+        """Test that std::unordered_map related structures are formatted correctly when printed.
----------------
aprantl wrote:
> just curious: what does the _with_run_command suffix mean? Or was this copied from another test?
Ah good catch. This was from at the `map` formatter test. Presumably the name refers to its usage of `self.runCmd`. I'll change it to something more meaningful


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D129364/new/

https://reviews.llvm.org/D129364



More information about the lldb-commits mailing list