[Lldb-commits] [PATCH] D125325: Pass plugin_name in SBProcess::SaveCore

Greg Clayton via Phabricator via lldb-commits lldb-commits at lists.llvm.org
Wed May 11 15:04:47 PDT 2022


clayborg added inline comments.


================
Comment at: lldb/include/lldb/API/SBProcess.h:340
 
   /// Save the state of the process in a core file (or mini dump on Windows).
+  lldb::SBError SaveCore(const char *file_name, const char *plugin_name);
----------------
I would modify the header doc to be a bit more descriptive. Also, the user doesn't need to know about the plug-in name, we should call it something else like maybe "flavor"? Right now we can save "mach-o" (from ObjectFileMachO) or "minidump" (from ObjectFileMinidump. We don't have ELF core file support yet in ObjectFileELF. So the users should be able to pick from a list. 


================
Comment at: lldb/include/lldb/API/SBProcess.h:341
   /// Save the state of the process in a core file (or mini dump on Windows).
+  lldb::SBError SaveCore(const char *file_name, const char *plugin_name);
+
----------------



================
Comment at: lldb/include/lldb/API/SBProcess.h:343
+
+  // Save the state of the process with the default plugin.
   lldb::SBError SaveCore(const char *file_name);
----------------



CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D125325/new/

https://reviews.llvm.org/D125325



More information about the lldb-commits mailing list