[Lldb-commits] [PATCH] D112309: [lldb] [Utility/UriParser] Replace port==-1 with llvm::None

Michał Górny via Phabricator via lldb-commits lldb-commits at lists.llvm.org
Fri Oct 22 05:06:05 PDT 2021


mgorny created this revision.
mgorny added reviewers: labath, teemperor, krytarowski, emaste.
mgorny requested review of this revision.

Use llvm::Optional<uint16_t> instead of int for port number
in UriParser::Parse(), and use llvm::None to indicate missing port
instead of a magic value of -1.


https://reviews.llvm.org/D112309

Files:
  lldb/include/lldb/Utility/UriParser.h
  lldb/source/Plugins/Platform/Android/PlatformAndroid.cpp
  lldb/source/Plugins/Platform/Android/PlatformAndroidRemoteGDBServer.cpp
  lldb/source/Plugins/Platform/gdb-server/PlatformRemoteGDBServer.cpp
  lldb/source/Plugins/Process/gdb-remote/GDBRemoteCommunicationServerLLGS.cpp
  lldb/source/Plugins/Process/gdb-remote/GDBRemoteCommunicationServerPlatform.cpp
  lldb/source/Utility/UriParser.cpp
  lldb/tools/lldb-server/Acceptor.cpp
  lldb/unittests/Host/ConnectionFileDescriptorTest.cpp
  lldb/unittests/Host/SocketTest.cpp
  lldb/unittests/Utility/UriParserTest.cpp

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D112309.381514.patch
Type: text/x-patch
Size: 11845 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/lldb-commits/attachments/20211022/71365810/attachment-0001.bin>


More information about the lldb-commits mailing list