[Lldb-commits] [PATCH] D111142: [lldb] [ABI] Apply AugmentRegisterInfo() to RemoteRegisterInfos
Pavel Labath via Phabricator via lldb-commits
lldb-commits at lists.llvm.org
Thu Oct 7 06:08:04 PDT 2021
labath added a comment.
I like everything except the class name. :)
I don't think it makes sense in the new location, and ideally I'd like to also use this for other plugins in the future (so that e.g. core file plugins don't have to excruciatingly list everything). Maybe we could move it into the the DynamicRegisterInfo class (as the intended use is to convert it to that eventually), and give it some generic name like `Register` or `Descriptor` or `RegisterDescriptor` ?
================
Comment at: lldb/include/lldb/Target/DynamicRegisterInfo.h:80-82
+ lldb_private::RegisterInfo *
+ GetRegisterInfo(llvm::StringRef reg_name);
+
----------------
What's up with this?
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D111142/new/
https://reviews.llvm.org/D111142
More information about the lldb-commits
mailing list