[Lldb-commits] [PATCH] D110619: [lldb] [DynamicRegisterInfo] Refactor SetRegisterInfo()

Michał Górny via Phabricator via lldb-commits lldb-commits at lists.llvm.org
Tue Sep 28 03:09:18 PDT 2021


mgorny created this revision.
mgorny added reviewers: labath, krytarowski, emaste, teemperor, krasimir, dblaikie.
mgorny requested review of this revision.

Move the "slice" and "composite" handling into separate methods to avoid
if/else hell.  Use more LLVM types whenever possible.  Replace printf()s
with llvm::Error combined with LLDB logging.


https://reviews.llvm.org/D110619

Files:
  lldb/source/Plugins/Process/Utility/DynamicRegisterInfo.cpp
  lldb/source/Plugins/Process/Utility/DynamicRegisterInfo.h

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D110619.375514.patch
Type: text/x-patch
Size: 13857 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/lldb-commits/attachments/20210928/001a2c82/attachment-0001.bin>


More information about the lldb-commits mailing list