[Lldb-commits] [PATCH] D108554: [lldb] Support querying registers via generic names without alt_names
Michał Górny via Phabricator via lldb-commits
lldb-commits at lists.llvm.org
Mon Aug 23 06:46:05 PDT 2021
mgorny created this revision.
mgorny added reviewers: labath, emaste, krytarowski, jasonmolenda, JDevlieghere.
mgorny requested review of this revision.
Update GetRegisterInfoByName() methods to support getting registers
by a generic name independently of alt_name entries in the register
context. This makes it possible to use generic names when interacting
with gdbserver (that does not supply alt_names). It also makes it
possible to remove some of the duplicated information from register
context declarations and/or use alt_names for another purpose.
https://reviews.llvm.org/D108554
Files:
lldb/source/Host/common/NativeRegisterContext.cpp
lldb/source/Target/RegisterContext.cpp
lldb/test/API/functionalities/gdb_remote_client/TestGDBServerTargetXML.py
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D108554.368093.patch
Type: text/x-patch
Size: 5101 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/lldb-commits/attachments/20210823/1ab8f995/attachment-0001.bin>
More information about the lldb-commits
mailing list