[Lldb-commits] [PATCH] D107780: [lldb] [gdb-remote] Implement fallback to vFile:stat for GetFileSize()

Michał Górny via Phabricator via lldb-commits lldb-commits at lists.llvm.org
Tue Aug 10 03:42:11 PDT 2021


mgorny updated this revision to Diff 365414.
mgorny added a comment.

Add a helper `Stat` method to take care of opening and closing the file. Add a cache variable for whether `vFile:size` is supported.


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D107780/new/

https://reviews.llvm.org/D107780

Files:
  lldb/source/Plugins/Process/gdb-remote/GDBRemoteCommunication.h
  lldb/source/Plugins/Process/gdb-remote/GDBRemoteCommunicationClient.cpp
  lldb/source/Plugins/Process/gdb-remote/GDBRemoteCommunicationClient.h
  lldb/test/API/functionalities/gdb_remote_client/TestGDBRemotePlatformFile.py

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D107780.365414.patch
Type: text/x-patch
Size: 8708 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/lldb-commits/attachments/20210810/5789046c/attachment.bin>


More information about the lldb-commits mailing list