[Lldb-commits] [PATCH] D98879: [lldb/PlatformPOSIX] Change LoadImage default to RTLD_LAZY
Dave Lee via Phabricator via lldb-commits
lldb-commits at lists.llvm.org
Fri Mar 19 13:17:24 PDT 2021
kastiglione added inline comments.
================
Comment at: lldb/source/Plugins/Platform/POSIX/PlatformPOSIX.cpp:609
if (!path_strings) {
- result_ptr->image_ptr = dlopen(name, 2);
+ result_ptr->image_ptr = dlopen(name, )" DLOPEN_OPTIONS R"();
if (result_ptr->image_ptr)
----------------
Instead of `DLOPEN_OPTIONS` and string concatenation, what do you think about defining `RTLD_LAZY` inside this string of code?
```
static const int RTLD_LAZY = 0x1;
/// codeā¦
result_ptr->image_ptr = dlopen(name, RTLD_LAZY);
```
The main reason I suggest this is putting the name inline like that makes it more grep friendly.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D98879/new/
https://reviews.llvm.org/D98879
More information about the lldb-commits
mailing list