[Lldb-commits] [PATCH] D94271: [lldb] Replace GetModuleAtIndexUnlocked and GetModulePointerAtIndexUnlocked with iterators (NFC)

Med Ismail Bennani via Phabricator via lldb-commits lldb-commits at lists.llvm.org
Thu Jan 7 16:52:33 PST 2021


mib added inline comments.


================
Comment at: lldb/include/lldb/Core/ModuleList.h:485-486
   typedef AdaptedIterable<collection, lldb::ModuleSP, vector_adapter>
       ModuleIterableNoLocking;
-  ModuleIterableNoLocking ModulesNoLocking() {
+  ModuleIterableNoLocking ModulesNoLocking() const {
     return ModuleIterableNoLocking(m_modules);
----------------
JDevlieghere wrote:
> mib wrote:
> > nit: Can we rename that to ModuleIterableNo**n**Locking and ModulesNo**n**Locking ?
> > 
> > Sounds more correct to me ^^
> If you feel strongly about it I can do it as a pre-commit change, but personally I don't think it's worth the churn.
Not really, it can remain as is.


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D94271/new/

https://reviews.llvm.org/D94271



More information about the lldb-commits mailing list