[Lldb-commits] [PATCH] D93266: [lldb/API] Expose Target::CreateBreakpoint(..., move_to_nearest_code) overload

Jonas Devlieghere via Phabricator via lldb-commits lldb-commits at lists.llvm.org
Mon Dec 14 18:58:32 PST 2020

JDevlieghere added inline comments.

Comment at: lldb/include/lldb/API/SBTarget.h:564
+  lldb::SBBreakpoint
+  BreakpointCreateByLocation(const lldb::SBFileSpec &file_spec, uint32_t line,
+                             uint32_t column, lldb::addr_t offset,
It's unfortunate that we have so many overloads, if we had to do it again I would've argued for something like `SBBreakpointLocationOptions` or something, but I'm not sure if that adds a lot, and dealing with defaults (such as the move_to_nearest_code) is hard because we have no SB counterpart for it. So I guess this is fine. 

Comment at: lldb/source/API/SBTarget.cpp:805-817
+    const LazyBool check_inlines = eLazyBoolCalculate;
+    const LazyBool skip_prologue = eLazyBoolCalculate;
+    const bool internal = false;
+    const bool hardware = false;
+    const FileSpecList *module_list = nullptr;
+    if (sb_module_list.GetSize() > 0) {
+      module_list = sb_module_list.get();
There's a lot of code duplication with the method just before it. Can we extract the common code into a private method that both call into? The reproducer instrumentation would remain in the public method. 

  rG LLVM Github Monorepo



More information about the lldb-commits mailing list