[Lldb-commits] [PATCH] D90011: [lldb] Redesign Target::GetUtilityFunctionForLanguage API
Pavel Labath via Phabricator via lldb-commits
lldb-commits at lists.llvm.org
Fri Oct 23 01:25:37 PDT 2020
labath accepted this revision.
labath added a comment.
This revision is now accepted and ready to land.
Sounds like a good idea.
================
Comment at: lldb/include/lldb/Symbol/TypeSystem.h:469
+ virtual std::unique_ptr<UtilityFunction>
+ GetUtilityFunction(std::string text, std::string name) {
+ return {};
----------------
Maybe this should be called **Create**UtilityFunction as well ?
================
Comment at: lldb/source/Plugins/LanguageRuntime/ObjC/AppleObjCRuntime/AppleObjCRuntimeV2.cpp:1371-1374
+ std::string error = llvm::toString(utility_fn_or_error.takeError());
LLDB_LOGF(log,
"Failed to get Utility Function for implementation lookup: %s",
+ error.c_str());
----------------
LLDB_LOG_ERROR
================
Comment at: lldb/source/Plugins/LanguageRuntime/ObjC/AppleObjCRuntime/AppleObjCRuntimeV2.cpp:1655-1658
+ std::string error = llvm::toString(utility_fn_or_error.takeError());
LLDB_LOGF(log,
"Failed to get Utility function for implementation lookup: %s.",
+ error.c_str());
----------------
ditto
================
Comment at: lldb/source/Plugins/LanguageRuntime/ObjC/AppleObjCRuntime/AppleObjCTrampolineHandler.cpp:818-822
+ std::string error = llvm::toString(utility_fn_or_error.takeError());
LLDB_LOGF(
log,
"Failed to get Utility Function for implementation lookup: %s.",
+ error.c_str());
----------------
here too
================
Comment at: lldb/source/Plugins/SystemRuntime/MacOSX/AppleGetItemInfoHandler.cpp:148-151
+ if (!utility_fn_or_error) {
+ std::string error = llvm::toString(utility_fn_or_error.takeError());
+ LLDB_LOGF(log, "Failed to create utility function: %s.",
+ error.c_str());
----------------
and here
================
Comment at: lldb/source/Plugins/TypeSystem/Clang/TypeSystemClang.cpp:9584
- return new ClangUtilityFunction(*target_sp.get(), text, name);
+ return std::make_unique<ClangUtilityFunction>(*target_sp.get(), text, name);
}
----------------
no std::move here
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D90011/new/
https://reviews.llvm.org/D90011
More information about the lldb-commits
mailing list