[Lldb-commits] [PATCH] D84336: [lldb] Cleanup CommandObject registration (NFC)

Jonas Devlieghere via Phabricator via lldb-commits lldb-commits at lists.llvm.org
Wed Jul 22 09:33:07 PDT 2020


JDevlieghere created this revision.
JDevlieghere added reviewers: labath, teemperor, mib.

- Remove the spurious argument to `CommandObjectScript`
- Use make_shared instead of bare `new`.
- Hide code duplication behind a macro.


Repository:
  rLLDB LLDB

https://reviews.llvm.org/D84336

Files:
  lldb/source/Interpreter/CommandInterpreter.cpp
  lldb/source/Interpreter/CommandObjectScript.cpp
  lldb/source/Interpreter/CommandObjectScript.h

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D84336.279849.patch
Type: text/x-patch
Size: 6000 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/lldb-commits/attachments/20200722/11a7d462/attachment.bin>


More information about the lldb-commits mailing list