[Lldb-commits] [PATCH] D77326: 1/2: [nfc] [lldb] Unindent code
Jan Kratochvil via Phabricator via lldb-commits
lldb-commits at lists.llvm.org
Sat Apr 4 01:25:15 PDT 2020
jankratochvil marked 4 inline comments as done.
jankratochvil added inline comments.
================
Comment at: lldb/source/Plugins/SymbolFile/DWARF/HashedNameToDIE.cpp:70-71
const dw_tag_t die_tag = die_info_array[i].tag;
- if (die_tag == 0 || die_tag == DW_TAG_class_type ||
- die_tag == DW_TAG_structure_type) {
- if (die_info_array[i].type_flags & eTypeFlagClassIsImplementation) {
- if (return_implementation_only_if_available) {
- // We found the one true definition for this class, so only return
- // that
- die_offsets.clear();
- die_offsets.emplace_back(die_info_array[i]);
- return;
- } else {
- // Put the one true definition as the first entry so it matches first
- die_offsets.emplace(die_offsets.begin(), die_info_array[i]);
- }
- } else {
+ if (die_tag != 0 && die_tag != DW_TAG_class_type &&
+ die_tag != DW_TAG_structure_type)
+ continue;
----------------
clayborg wrote:
> clayborg wrote:
> > This logic is easy to understand by reading the code.
> This logic is harder to follow. Maybe:
> ```
> if (!(die_tag == 0 || die_tag == DW_TAG_class_type || die_tag == DW_TAG_structure_type))
> continue;
> ```
>
OK, changed it.
I will follow this also IMO more readable form, I changed it since a [[ https://sourceware.org/pipermail/gdb-patches/2010-July/076305.html | 10 years old review ]] but that does not matter anymore.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D77326/new/
https://reviews.llvm.org/D77326
More information about the lldb-commits
mailing list