[Lldb-commits] [PATCH] D76808: Fix handling of bit-fields when there is a base class when parsing DWARF

Adrian Prantl via Phabricator via lldb-commits lldb-commits at lists.llvm.org
Wed Mar 25 16:16:56 PDT 2020


aprantl accepted this revision.
aprantl added a comment.
This revision is now accepted and ready to land.

Couple of minor suggestions inside.



================
Comment at: lldb/source/Plugins/SymbolFile/DWARF/DWARFASTParserClang.cpp:2671
               // If we have a gap between the last_field_end and the current
               // field we have an unnamed bit-field
               if (this_field_info.bit_offset != last_field_end &&
----------------
do we need to amend the comment to describe the new conditions?


================
Comment at: lldb/source/Plugins/SymbolFile/DWARF/DWARFASTParserClang.cpp:2673
               if (this_field_info.bit_offset != last_field_end &&
-                  !(this_field_info.bit_offset < last_field_end)) {
+                  !(this_field_info.bit_offset < last_field_end) &&
+                  !(last_field_info.bit_offset == 0 &&
----------------
`(this_field_info.bit_offset > last_field_end)` ?


================
Comment at: lldb/source/Plugins/SymbolFile/DWARF/DWARFASTParserClang.cpp:2674
+                  !(this_field_info.bit_offset < last_field_end) &&
+                  !(last_field_info.bit_offset == 0 &&
+                    last_field_info.bit_size == 0 &&
----------------
```
(last_field_info.bit_offset > 0) ||
(last_field_info.bit_size > 0) ||
!layout_info.base_offsets.size())
```

Does this get more readable if you sink the ! into the subexpressions?


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D76808/new/

https://reviews.llvm.org/D76808





More information about the lldb-commits mailing list