[Lldb-commits] [PATCH] D73119: [lldb/Initializers] Rename plugins to match their entry points
Pavel Labath via Phabricator via lldb-commits
lldb-commits at lists.llvm.org
Tue Jan 21 09:51:39 PST 2020
labath added a comment.
Herald added a subscriber: wuzish.
There are three names to consider here:
- the name of the cmake target
- the name of the main .h file
- the name of the folders the plugin is in
Here you seem to be standardizing the first two, sometimes at the expense breaking existing symmetry with the third one (lldbPluginProcessMacOSXKernel -> lldbPluginProcessKDP) . Could we make all three consistent? I don't know whether you'll need that for the auto-generation, but it sure won't hurt..
CHANGES SINCE LAST ACTION
More information about the lldb-commits