[Lldb-commits] [PATCH] D71262: [lldb] "See through" atomic types in ClangASTContext
Raphael Isemann via Phabricator via lldb-commits
lldb-commits at lists.llvm.org
Tue Dec 10 05:53:07 PST 2019
teemperor accepted this revision.
teemperor added a comment.
This revision is now accepted and ready to land.
LGTM beside my inline comment about the function name.
Comment at: lldb/source/Symbol/ClangASTContext.cpp:2483
+ type = cast<clang::AtomicType>(type)->getValueType();
In this case I would rename it to something like `getUnderlyingType`, `unpackType`, `removeWrappingTypes` or something like that. We shouldn't have our own definition of 'desugar' that differs from Clang's definition.
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
More information about the lldb-commits