[Lldb-commits] [PATCH] D70668: [lldb][NFC] Allow range-based for-loops on VariableList

Pavel Labath via Phabricator via lldb-commits lldb-commits at lists.llvm.org
Mon Nov 25 05:44:46 PST 2019


labath accepted this revision.
labath added a comment.
This revision is now accepted and ready to land.

Since copying shared pointers isn't completely cheap, I think we should use `const shared_ptr &`s whereever possible. Also, the typical lldb naming convention for shared_pointer variables is to have them end in `_sp`, so I'd try to preserve that.
Besides that, LGTM.


Repository:
  rLLDB LLDB

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D70668/new/

https://reviews.llvm.org/D70668





More information about the lldb-commits mailing list