[Lldb-commits] [PATCH] D68951: Fix test breakage caused by r374424

Lawrence D'Anna via Phabricator via lldb-commits lldb-commits at lists.llvm.org
Mon Oct 14 11:39:49 PDT 2019


lawrence_danna created this revision.
lawrence_danna added reviewers: JDevlieghere, jasonmolenda, labath, stella.stamenova.
Herald added a project: LLDB.

The build directory name is based on the test method name, so having
two test methods with the same name in the same test file is a
problem, even if they're in different test classes.

On linux and darwin this conflict can go unnoticed, but windows 
has different filesystem semantics and it will fail when one
process tries to delete files still held open by another.

The problem is fixed just by changing the name of one of the test
methods.


Repository:
  rG LLVM Github Monorepo

https://reviews.llvm.org/D68951

Files:
  lldb/packages/Python/lldbsuite/test/python_api/interpreter/TestRunCommandInterpreterAPI.py


Index: lldb/packages/Python/lldbsuite/test/python_api/interpreter/TestRunCommandInterpreterAPI.py
===================================================================
--- lldb/packages/Python/lldbsuite/test/python_api/interpreter/TestRunCommandInterpreterAPI.py
+++ lldb/packages/Python/lldbsuite/test/python_api/interpreter/TestRunCommandInterpreterAPI.py
@@ -30,7 +30,7 @@
         self.dbg.SetErrorFileHandle (self.devnull, False)
 
     @add_test_categories(['pyapi'])
-    def test_run_session_with_error_and_quit(self):
+    def test_run_session_with_error_and_quit_legacy(self):
         """Run non-existing and quit command returns appropriate values"""
 
         n_errors, quit_requested, has_crashed = self.dbg.RunCommandInterpreter(


-------------- next part --------------
A non-text attachment was scrubbed...
Name: D68951.224884.patch
Type: text/x-patch
Size: 744 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/lldb-commits/attachments/20191014/ed5f1da3/attachment.bin>


More information about the lldb-commits mailing list