[Lldb-commits] [PATCH] D68160: File::Clear() -> File::TakeStreamAndClear()
Pavel Labath via Phabricator via lldb-commits
lldb-commits at lists.llvm.org
Sun Sep 29 23:34:19 PDT 2019
labath accepted this revision.
labath added a comment.
This revision is now accepted and ready to land.
Sounds good. If this were a more permanent interface, I'd argue that the function should be called `TakeStream` (in analogy with `llvm::Expected::takeError`), but for a temporary thing that does not matter...
================
Comment at: lldb/source/Host/common/File.cpp:166-167
+FILE *File::TakeStreamAndClear() {
+ GetStream();
+ FILE *stream = m_stream;
+ m_stream = NULL;
----------------
`FILE *stream = GetStream()` ?
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D68160/new/
https://reviews.llvm.org/D68160
More information about the lldb-commits
mailing list