[Lldb-commits] [PATCH] D65128: [Logging] Replace Log::Printf with LLDB_LOG macro (NFC)
Jim Ingham via Phabricator via lldb-commits
lldb-commits at lists.llvm.org
Mon Jul 22 18:54:43 PDT 2019
jingham requested changes to this revision.
jingham added a comment.
This revision now requires changes to proceed.
Actually, I don't want this change as is. Some logs - like the expression and step logs - are laid out for readability, and LLDB_LOG automatically adds the file & function which will make them much harder to read.
We need a variant that doesn't inject this information, and then this change should use that variant. Or we can remove the file & function from LLDB_LOG and decide to let the people add those as they wish. I don't have a strong opinion one way or the other, but I certainly don't want this extra noise in the step or expression logs.
CHANGES SINCE LAST ACTION
More information about the lldb-commits