[Lldb-commits] [PATCH] D64159: [Core] Generalize ValueObject::MaybeCalculateCompleteType

Alex Langford via Phabricator via lldb-commits lldb-commits at lists.llvm.org
Mon Jul 8 14:33:50 PDT 2019

xiaobai marked 2 inline comments as done.
xiaobai added inline comments.

Comment at: include/lldb/Target/ObjCLanguageRuntime.h:253
+  CompilerType CalculateCompleteType(CompilerType base_type) override;
clayborg wrote:
> Is this named correctly? Maybe this should be named "CompilerType GetRuntimeType(CompilerType base_type) override;"? 
> What this function does is gets the real definition from the objective C runtime at the moment. This name would better reflect what is going on and would be something we might ask of a runtime.
I have no problem with renaming it "GetRuntimeType". Will do that.

Comment at: source/Target/ObjCLanguageRuntime.cpp:403
+ObjCLanguageRuntime::CalculateCompleteType(CompilerType base_type) {
+  CompilerType type_to_return;
clayborg wrote:
> So a main question for ObjC here: do we always want to show the runtime type? Should we not check if the class inside of "base_type" is the one true definition and skip grabbing the runtime type here and return {}?
How do you know which is the "one true definition"?



More information about the lldb-commits mailing list