[Lldb-commits] [PATCH] D61299: Rename Minion to ASTImporterDelegate

Gabor Marton via Phabricator via lldb-commits lldb-commits at lists.llvm.org
Tue Apr 30 11:00:14 PDT 2019


martong added inline comments.


================
Comment at: lldb/include/lldb/Symbol/ClangASTImporter.h:259
     public:
-      CxxModuleScope(Minion &minion, clang::ASTContext *dst_ctx)
+      CxxModuleScope(ASTImporterDelegate &minion, clang::ASTContext *dst_ctx)
           : m_minion(minion) {
----------------
The name of the parameter is still `minion` ... if the goal is to completely wipe out the old name then perhaps these should be renamed. Also with the new type name it just feels odd.


Repository:
  rLLDB LLDB

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D61299/new/

https://reviews.llvm.org/D61299





More information about the lldb-commits mailing list