[Lldb-commits] [PATCH] D60780: [tools] Only build lldb-instr and lldb-vscode if asked.

Jonas Devlieghere via Phabricator via lldb-commits lldb-commits at lists.llvm.org
Tue Apr 16 11:16:15 PDT 2019

JDevlieghere added a comment.

In D60780#1468927 <https://reviews.llvm.org/D60780#1468927>, @labath wrote:

> LLDB_TOOL_$TOOL_BUILD would be a better name for consistency with llvm. In fact, if we started using the llvm cmake macros like `add_llvm_subdirectory`, it would handle this automatically, including creating the cache variable.
> The only difference would be that the variable would default to "On", whereas you seem to want default-off. (I'm a bit torn on whether this is good. On one hand, I understand the desire to not build this stuff, but on the other, this creates an inconsistency with llvm, which builds everything by default, and consistency is a good thing.)
> Also, I'd like to nominate lldb-mi as an additional optional feature. :)

+1 on everything Pavel said. I'd also prefer to keep this on by default.

  rG LLVM Github Monorepo



More information about the lldb-commits mailing list