[Lldb-commits] [PATCH] D54454: Be more permissive in what we consider a variable name.
Jim Ingham via Phabricator via lldb-commits
lldb-commits at lists.llvm.org
Mon Nov 12 16:34:54 PST 2018
jingham added a comment.
Those seem legit things to try to capture, though a little esoteric. Since "frame variable" and "target variable" didn't support these constructs before you should certainly add some tests for that.
The frame variable parser also supports:
(lldb) frame variable foo
where foo is anything that can produce "vector" like children (e.g. std::vector's). Will your change work with that?
More information about the lldb-commits