[Lldb-commits] [PATCH] D54003: Refactor ClangASTContext::AddEnumerationValueToEnumerationType() to remove redundant parameter which can be calculated from other parameter

Davide Italiano via Phabricator via lldb-commits lldb-commits at lists.llvm.org
Thu Nov 1 15:14:37 PDT 2018


davide added inline comments.


================
Comment at: packages/Python/lldbsuite/test/expression_command/radar_43822994/TestScopedEnumType.py:42
+        ## integral is not implicitly convertible to a scoped enum
+        value = frame.EvaluateExpression("1 == Foo::FooBar")
+        self.assertTrue(value.IsValid())
----------------
This clearly looks like can be an inline test (and probably would make the thing more readable, IMHO).


https://reviews.llvm.org/D54003





More information about the lldb-commits mailing list