[Lldb-commits] [PATCH] D50071: Use rich mangling information in Symtab::InitNameIndexes()
Stefan Gränitz via Phabricator via lldb-commits
lldb-commits at lists.llvm.org
Mon Aug 6 04:48:42 PDT 2018
sgraenitz added a comment.
Ok I will fix the details, rebase and update the review.
Btw: I also spilt off the `ConstString::IsNull()` addition with unit test and fix in `Mangled` to https://reviews.llvm.org/D50327
================
Comment at: source/Core/RichManglingInfo.cpp:126
+ case ItaniumPartialDemangler: {
+ auto multi_in_out = m_IPD_size;
+ auto buf = m_IPD.getFunctionBaseName(m_IPD_buf, &multi_in_out);
----------------
labath wrote:
> sgraenitz wrote:
> > Not sure about `multi_in_out` as a name here. It's hard to find one that fits the purpose and stays below 30 chars.. IPD calls it `N`.
> The name makes no difference to me. However, if you think it makes sense, you could try passing `getFunctionBaseName` as a member function pointer into the helper function, so that all of the buffer handling is completely hidden inside that function.
Thought about that, but didn't want to over-engineer this. It might be revisited in case we add more accessors in the future.
https://reviews.llvm.org/D50071
More information about the lldb-commits
mailing list