[Lldb-commits] [PATCH] D48295: [WIP] Implement new ReturnMIStatus method of CMICmdBase class.

Adrian Prantl via Phabricator via lldb-commits lldb-commits at lists.llvm.org
Tue Jun 19 09:57:13 PDT 2018


aprantl added a comment.

In https://reviews.llvm.org/D48295#1136692, @apolyakov wrote:

> I don't completely understand what you mean. First of all, what do you mean when talking about success_handlers? 'cause if you mean success_handler from `Execute` function, then I should say that it doesn't have to set an error, it might be any. Secondly, `status` in your example is a function, how can it has a `takeError` method?


`status` is meant to be a `bool`. I think `success_handler` was a bad name. It should probably be called `action` or `command` something similar. It would be the actual implementation of the command, such as lambda that is assigned to `success_handler` in your patch.


https://reviews.llvm.org/D48295





More information about the lldb-commits mailing list