[Lldb-commits] [PATCH] D48060: Introduce lldb-framework CMake target and centralize its logic

Alex Langford via Phabricator via lldb-commits lldb-commits at lists.llvm.org
Fri Jun 15 14:00:35 PDT 2018


xiaobai added a comment.
xiaobai added inline comments.


================
Comment at: cmake/modules/AddLLDB.cmake:102-104
   if(LLDB_BUILD_FRAMEWORK)
     if(ARG_INCLUDE_IN_FRAMEWORK)
+      add_dependencies(lldb-framework ${name})
----------------
labath wrote:
> If you reorder this slightly, then you should be able to get rid of the extra dependency code in main CMakeLists.txt.
> Something like this:
> ```
> if (ARG_INCLUDE_IN_FRAMEWORK)
>   add_dependencies(lldb-suite ${name})
>   if (LLDB_BUILD_FRAMEWORK)
>     ...
> ```
> 
> (of course, then the INCLUDE_IN_FRAMEWORK arg will become misnamed, but that can be solved by renaming it to INCLUDE_IN_SUITE)
This is a pretty good idea imo. I think it'll make the dependency tracking much easier. The lldb-framework target then becomes a small target.


https://reviews.llvm.org/D48060





More information about the lldb-commits mailing list