[Lldb-commits] [PATCH] D47991: Improve SBThread's stepping API using SBError parameter.

Alexander Polyakov via Phabricator via lldb-commits lldb-commits at lists.llvm.org
Tue Jun 12 03:06:23 PDT 2018


apolyakov updated this revision to Diff 150913.
apolyakov added a comment.

Some readability improvements(more comments). I think that we should keep `StepOver` signature as

  void StepOver(SBError &error, lldb::RunMode stop_other_threads);

since it seems that in SBThread methods SBError paramater is the last non-optional one, as @aprantl said.


https://reviews.llvm.org/D47991

Files:
  include/lldb/API/SBThread.h
  scripts/interface/SBThread.i
  source/API/SBThread.cpp

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D47991.150913.patch
Type: text/x-patch
Size: 9707 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/lldb-commits/attachments/20180612/cf05ec48/attachment-0001.bin>


More information about the lldb-commits mailing list