[Lldb-commits] [PATCH] D46318: lldb-test symbols: Add ability to do name-based lookup

Zachary Turner via Phabricator via lldb-commits lldb-commits at lists.llvm.org
Tue May 1 09:50:41 PDT 2018


zturner added inline comments.


================
Comment at: lit/CMakeLists.txt:32
+if(TARGET lld)
+  list(APPEND LLDB_TEST_DEPS lld)
+  set(LLDB_HAVE_LLD 1)
----------------
Note that this depends on lld having had its own `CMakeLists.txt` file processed before LLDB's.  I think this happens by accident since we process them in alphabetical order, but it's something to keep in mind.


================
Comment at: lit/SymbolFile/DWARF/basic-function-lookup.cpp:23
+void foo() {}
+// BASE-DAG: name = "foo()", mangled = "_Z3foov"
+// FULL-DAG: name = "foo()", mangled = "_Z3foov"
----------------
I personally find it a little confusing to have the check lines interspersed with the source code here as we do in this file.  I think it's easier to read if all check labels are grouped together so that you get a general idea of what the output of the tool looks like.  I don't feel too strongly though, so up to you.


https://reviews.llvm.org/D46318





More information about the lldb-commits mailing list