[Lldb-commits] [PATCH] D40467: DWZ 04/12: Separate Offset also into FileOffset

Greg Clayton via Phabricator via lldb-commits lldb-commits at lists.llvm.org
Mon Nov 27 10:17:42 PST 2017

clayborg added a comment.

It would be much easier to read this patch if there were no renames from "*offset" to "*file_offset". Can we remove these extra renames where it isn't needed?

Comment at: source/Plugins/SymbolFile/DWARF/DWARFDebugInfo.h:15
 #include <vector>
+#include <mutex>
Why is this added here? Doesn't seem to be needed, or it should be moved to .cpp file?


More information about the lldb-commits mailing list