[Lldb-commits] [PATCH] D34681: [DWARFCallFrameInfo] Add Type enum to differentiate eh/debug_frame sections

Pavel Labath via Phabricator via lldb-commits lldb-commits at lists.llvm.org
Tue Jun 27 04:33:37 PDT 2017


labath created this revision.

instead of using a boolean to differentiate between the two section
types, use an enum to make the intent clearer.

I also remove the RegisterKind argument from the constructor, as this
can be deduced from the Type argument.


https://reviews.llvm.org/D34681

Files:
  include/lldb/Symbol/DWARFCallFrameInfo.h
  source/Plugins/ObjectFile/Mach-O/ObjectFileMachO.cpp
  source/Symbol/DWARFCallFrameInfo.cpp
  source/Symbol/UnwindTable.cpp
  unittests/Symbol/TestDWARFCallFrameInfo.cpp

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D34681.104136.patch
Type: text/x-patch
Size: 9361 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/lldb-commits/attachments/20170627/1a70da4d/attachment.bin>


More information about the lldb-commits mailing list