[Lldb-commits] [PATCH] D14177: Better handle the arguments common to all MI commands.

Ilia K via lldb-commits lldb-commits at lists.llvm.org
Thu Oct 29 08:16:53 PDT 2015


ki.stfu added inline comments.

================
Comment at: tools/lldb-mi/MICmdBase.h:68
@@ -67,2 +67,3 @@
     virtual MIuint GetGUID();
+    void ParseCommonArgs();
 
----------------
How about renaming it to AddCommonArgs and making it protected?

================
Comment at: tools/lldb-mi/MICmdInvoker.cpp:192
@@ -191,3 +191,3 @@
 
-    if (bOk && !vCmd.ParseArgs())
+    if(bOk)
     {
----------------
nic: add a space please


http://reviews.llvm.org/D14177





More information about the lldb-commits mailing list