[Lldb-commits] [PATCH] Implement initial Altivec support
Justin Hibbits
jrh29 at alumni.cwru.edu
Thu Jan 29 09:33:59 PST 2015
In http://reviews.llvm.org/D7039#115003, @emaste wrote:
> I'm not familiar with low-level ppc details but overall looks fine to me.
>
> Two minor comments,
>
> - `reg_info->name[0] == 'v'` feels somewhat kludgey.
> - We'll need a similar change on x86; I think `vregset` is probably a sufficiently generic name.
You're right, it is a kludge. I followed the FPR check, which I think I copied from somewhere else. I've since fixed both, with an IsFPR() for the FPR check, and added a 'IsVMX()' function to check VMX registers.
REPOSITORY
rL LLVM
http://reviews.llvm.org/D7039
EMAIL PREFERENCES
http://reviews.llvm.org/settings/panel/emailpreferences/
More information about the lldb-commits
mailing list