[Lldb-commits] [PATCH] Rename lldb register enums to contain lldb_ prefix

Zachary Turner zturner at google.com
Thu Nov 20 17:24:06 PST 2014

Hi clayborg, jingham,

LLDB supports many different register numbering schemes, and these are typically prefixed with an indicator that lets the user know what numbering scheme is used.  The gcc numbering scheme is prefixed with gcc, and there are similar ones for dwarf, gdb, and gcc_dwarf.  Examples of these registers are gcc_eax_i386, or gcc_dwarf_mm2_x86_64. 

LLDB also contains its own internal numbering scheme, but the enum for LLDB's numbering scheme was prefixed differently.  This patch updates changes the names of these enums to use the same naming scheme for the enum values as the rest of the register kinds by removing gpr_ and fpu_ prefixes, and instead using lldb_ prefixes for all enum values.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: D6351.16464.patch
Type: text/x-patch
Size: 76059 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/lldb-commits/attachments/20141121/65300110/attachment.bin>

More information about the lldb-commits mailing list