[Lldb-commits] [PATCH] Use break_id_t instead of user_id_t

Stephen Wilson wilsons at start.ca
Fri Jul 16 17:43:15 PDT 2010

Hi all,

This patch changes Process::CreateBreakpointSite to return a break_id_t
instead of a user_id_t.  Also, update ResolveBreakpointSite to check
for invalid breakpoint ID's using the proper magic constant.

OK to apply?

Take care,

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: break-id.patch
URL: <http://lists.llvm.org/pipermail/lldb-commits/attachments/20100716/daaa1417/attachment.ksh>

More information about the lldb-commits mailing list