[libcxx-commits] [PATCH] D157193: [libc++][ranges] P2116R9: Implements `views::enumerate`
Hristo Hristov via Phabricator via libcxx-commits
libcxx-commits at lists.llvm.org
Sun Oct 22 03:54:47 PDT 2023
H-G-Hristov added inline comments.
================
Comment at: libcxx/test/std/ranges/range.adaptors/range.enumerate/sentinel/equal.pass.cpp:48
+constexpr bool tests() {
+ test<cpp17_input_iterator<int*>>();
+ test<cpp20_input_iterator<int*>>();
----------------
var-const wrote:
> It should be possible to use `types::for_each` to cut down on the boilerplate a little bit (from `type_algorithms.h`). Applies to other similar parts of the patch as well.
All other tests in ranges use this pattern. I fails to see how `types::for_each` will improve readability. Anyway I can do it if you prefer the tests to use `types::for_each`.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D157193/new/
https://reviews.llvm.org/D157193
More information about the libcxx-commits
mailing list