[libcxx-commits] [PATCH] D130695: [libc++][ranges]Refactor `copy{, _backward}` and `move{, _backward}`

Louis Dionne via Phabricator via libcxx-commits libcxx-commits at lists.llvm.org
Fri Sep 23 13:57:18 PDT 2022


ldionne added a comment.

In D130695#3805381 <https://reviews.llvm.org/D130695#3805381>, @philnik wrote:

>> - `unconstrainted_reverse_iterator` can now be removed (which I intend to do in a follow-up), removing a lot of code duplication and complexity.
>
> Do you already have that follow-up? I don't know how much extra complexity will result in removing `__unconstrained_reverse_iterator`.

We looked at it briefly and it didn't seem to incur much penalty. FWIW, I think removing the need for `__unconstrained_reverse_iterator` (and generally speaking the use of `reverse_iterator` as an implementation detail of low-level algorithms) is by far the most important motivation, at least for me.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D130695/new/

https://reviews.llvm.org/D130695



More information about the libcxx-commits mailing list