[libcxx-commits] [PATCH] D128181: [libc++] Make _LIBCPP_DEBUG_RANDOMIZE_RANGE a function

Louis Dionne via Phabricator via libcxx-commits libcxx-commits at lists.llvm.org
Thu Jun 30 05:27:30 PDT 2022


ldionne accepted this revision.
ldionne added a comment.
This revision is now accepted and ready to land.

LGTM once CI is green and all comments have been applied.



================
Comment at: libcxx/include/CMakeLists.txt:323
   __iterator/wrap_iter.h
+  __libcxx/debug_randomize_range.h
   __locale
----------------
Let's call this `__debug_utils/randomize_range.h` for now, and eventually we can actually rename it to `__debug/randomize_range.h`, and rename the current `__debug` header to something else. WDYT? `__libcxx/` definitely looks out of place.


================
Comment at: libcxx/include/__algorithm/partial_sort.h:23-25
 #if defined(_LIBCPP_DEBUG_RANDOMIZE_UNSPECIFIED_STABILITY)
 #  include <__algorithm/shuffle.h>
 #endif
----------------
This can be removed (here and in the other headers).


================
Comment at: libcxx/include/__libcxx/debug_randomize_range.h:12
+
+#include <__algorithm/shuffle.h>
+#include <__config>
----------------
Maybe guard this include with `#ifdef _LIBCPP_DEBUG_RANDOMIZE_UNSPECIFIED_STABILITY`?


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D128181/new/

https://reviews.llvm.org/D128181



More information about the libcxx-commits mailing list