[libcxx-commits] [PATCH] D130124: [libc++][ranges] fix `std::search_n` incorrect `static_assert`
Joe Loser via Phabricator via libcxx-commits
libcxx-commits at lists.llvm.org
Tue Jul 19 14:36:40 PDT 2022
jloser added inline comments.
================
Comment at: libcxx/test/std/algorithms/alg.nonmodifying/alg.search/search_n_pred.pass.cpp:189
test<random_access_iterator<const int*> >();
-
+ testStaticAssertBug();
#if TEST_STD_VER > 17
----------------
huixie90 wrote:
> jloser wrote:
> > Nit: can we give a better name to this function?
> Any suggestions? I agree it is a terrible name. It is my failed attempt to give it a reasonable name
Maybe `test_binary_predicate_callable`? Note the camel case instead to match that of `test_constexpr` for example.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D130124/new/
https://reviews.llvm.org/D130124
More information about the libcxx-commits
mailing list