[libcxx-commits] [PATCH] D117324: [libc++] [NFC] Small cleanups in move_iterator.h
Arthur O'Dwyer via Phabricator via libcxx-commits
libcxx-commits at lists.llvm.org
Fri Jan 14 08:23:48 PST 2022
Quuxplusone created this revision.
Quuxplusone added reviewers: ldionne, libc++.
Quuxplusone added a project: libc++.
Quuxplusone requested review of this revision.
Herald added a subscriber: libcxx-commits.
Herald added 1 blocking reviewer(s): libc++.
Three NFC patches in one. The first two are completely mechanical; the third simply shuffles around some declarations so as to shrink the diff when C++20 `move_iterator` is finally implemented.
[libc++] Rename __i to __current_ in move_iterator. NFC.
[libc++] s/_LIBCPP_INLINE_VISIBILITY/_LIBCPP_HIDE_FROM_ABI/g in move_iterator.h. NFC.
[libc++] Further small cleanups of move_iterator.h. NFC.
Repository:
rG LLVM Github Monorepo
https://reviews.llvm.org/D117324
Files:
libcxx/include/__iterator/move_iterator.h
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D117324.400017.patch
Type: text/x-patch
Size: 9866 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/libcxx-commits/attachments/20220114/df3f368e/attachment.bin>
More information about the libcxx-commits
mailing list