[libcxx-commits] [PATCH] D100132: [libunwind][AIX] implementation of the unwinder for AIX
Xing Xue via Phabricator via libcxx-commits
libcxx-commits at lists.llvm.org
Tue Jan 11 09:27:27 PST 2022
xingxue updated this revision to Diff 398978.
xingxue marked an inline comment as done.
xingxue added a comment.
Addressed comments.
- allow the declaration of `_Unwind_GetTextRelBase()` on AIX.
- rename `getFuncName` to `getFuncNameFromTBTable`.
- rename `clangFrame` to `frameWithEHInfo` and rename `classicFrame` to `frameWithXLEHStateTable`.
- add comments to describe the code looking for `eh_info` and dealing with the complexity arising from some XL compiler versions use the wrong ordering of flag bits.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D100132/new/
https://reviews.llvm.org/D100132
Files:
libunwind/include/__libunwind_config.h
libunwind/include/libunwind.h
libunwind/include/unwind.h
libunwind/src/AddressSpace.hpp
libunwind/src/CMakeLists.txt
libunwind/src/Registers.hpp
libunwind/src/UnwindCursor.hpp
libunwind/src/UnwindLevel1-gcc-ext.c
libunwind/src/UnwindLevel1.c
libunwind/src/UnwindRegistersRestore.S
libunwind/src/UnwindRegistersSave.S
libunwind/src/Unwind_AIXExtras.cpp
libunwind/src/assembly.h
libunwind/src/config.h
libunwind/src/libunwind.cpp
libunwind/src/libunwind_ext.h
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D100132.398978.patch
Type: text/x-patch
Size: 47162 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/libcxx-commits/attachments/20220111/6837a202/attachment-0001.bin>
More information about the libcxx-commits
mailing list