[libcxx-commits] [PATCH] D119881: [libc++] Remove cpp17_input_iterator.h
Arthur O'Dwyer via Phabricator via libcxx-commits
libcxx-commits at lists.llvm.org
Tue Feb 15 13:14:22 PST 2022
Quuxplusone accepted this revision.
Quuxplusone added a comment.
This revision is now accepted and ready to land.
Awesome, LGTM if CI is green.
Pre-existing issues that could be worth fixing in a followup PR if you're interested:
- `iter_alloc.pass.cpp` should be named `iter_iter.pass.cpp`/`iter_iter_alloc.pass.cpp`.
- It should test all the different test iterators, not just `It=char*` and `It=cpp17_input_iterator<const char*>`.
- It should be refactored in the obvious way to `test<It>()` instead of `test(It, It)`, to cut down on repetition.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D119881/new/
https://reviews.llvm.org/D119881
More information about the libcxx-commits
mailing list