[libcxx-commits] [PATCH] D119769: [libc++] Move everything related solely to _LIBCPP_ASSERT to its own file
Arthur O'Dwyer via Phabricator via libcxx-commits
libcxx-commits at lists.llvm.org
Tue Feb 15 08:56:40 PST 2022
Quuxplusone added inline comments.
================
Comment at: libcxx/include/CMakeLists.txt:102
__algorithm/upper_bound.h
+ __assert
__availability
----------------
philnik wrote:
> Quuxplusone wrote:
> > Are we at all worried about name conflicts? (Or stylistically about adding new top-level detail headers?) Should this be something like `__utility/libcpp_assert.h` instead?
> > OTOH, maybe we keep it like this right now, and then at some point in the future we move `__assert` to `__foo/libcpp_assert.h` and `__debug` to `__foo/debug_iterators.h` in the same commit, for some value of `__foo` on which I'm sure we'll disagree. :)
> I'm definitely in favor of moving that stuff into some directory. Maybe `__libcpp/`? That would most likely not clash with any new C++ headers and we could leave the `libcpp_` prefix out.
> and we could leave the `libcpp_` prefix out.
I don't want to get into a situation where `<assert.h>` means one thing and `"./assert.h"` means a different thing, so the prefix would need to stay even in that case. (Likewise, if we ever granularize `<string>`, I'll oppose the creation of `__string/string.h`. But luckily in that case it'll be `__string/basic_string.h` so the issue won't arise.)
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D119769/new/
https://reviews.llvm.org/D119769
More information about the libcxx-commits
mailing list