[libcxx-commits] [PATCH] D119159: [libc++] Make shared_ptr move unique_ptr's deleter

Asher Mancinelli via Phabricator via libcxx-commits libcxx-commits at lists.llvm.org
Mon Feb 7 10:01:44 PST 2022


ashermancinelli added inline comments.


================
Comment at: libcxx/include/__memory/shared_ptr.h:656
+         is_convertible<typename unique_ptr<_Yp, _Dp>::pointer, element_type*>::value &&
+         is_move_constructible<_Dp>::value
     > >
----------------
Should the requirement be added here, or should we reuse `__shared_ptr_deleter_ctor_reqs`? libstdc++ has a similar alias template used here that sfinaes away without `move_constructible`. That might be more readable, even though the alias template would only be used here iiuc. Also, would it be nicer to use `_And`?


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D119159/new/

https://reviews.llvm.org/D119159



More information about the libcxx-commits mailing list