[libcxx-commits] [PATCH] D103765: [libc++] Update atomic synopsis and tests.

Mark de Wever via Phabricator via libcxx-commits libcxx-commits at lists.llvm.org
Tue Oct 12 08:25:34 PDT 2021


Mordante marked an inline comment as done.
Mordante added inline comments.


================
Comment at: libcxx/include/atomic:272
+template<class T>
+  void atomic_store(volatile atomic<T>*, typename atomic<T>::value_type) noexcept;
+template<class T>
----------------
ldionne wrote:
> We could perhaps drop the `typename` here for readability, since this is only in a comment. WDYT?
I don't mind to remove them. It might be they're not even required in C++20, but too lazy too look for the details of the paper.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D103765/new/

https://reviews.llvm.org/D103765



More information about the libcxx-commits mailing list